Kjøre planlagte oppgaver regelmessig

Slik kjører du planlagte oppgaver regelmessig

Oppgaveplanlegging er et verktøy du bruker til å fastsette at programmer (for eksempel Diskdefragmentering) skal kjøres regelmessig, når det passer best for deg. Oppgaveplanlegging starter hver gang du starter Windows, og kjøres i bakgrunnen.

Du kan åpne Oppgaveplanlegging ved å klikke startknappen, velge Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.

Med Oppgaveplanlegging kan du gjøre følgende:

  • Planlegge at en oppgave skal kjøres daglig, ukentlig, månedlig eller på bestemte tidspunkt, for eksempel når maskinen startes eller er inaktiv.
  • Endre tidsplanen for eller deaktivere en eksisterende oppgave.
  • Tilpasse hvordan en oppgave skal utføres på det planlagte tidspunktet.


Planlegge en ny oppgave

Slik planlegger du en ny oppgave

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Dobbeltklikk mappen Legg til planlagt oppgave.
  3. Følg instruksjonene i veiviseren for planlagte oppgaver.

    4. Hvis du vil angi avanserte innstillinger for oppgaven (for eksempel angi at den skal kjøres flere ganger etter hverandre hver gang den kjøres), må du merke av for Åpne avanserte egenskaper i det siste skjermbildet i veiviseren.

Obs!

  • Hvis oppgaveprogrammet krever parametere, merker du av for Åpne avanserte egenskaper i det siste skjermbildet i veiviseren, velger Fullfør, velger kategorien Oppgave, og skriver inn parameterne i Kjør-boksen, etter oppgavebanen.
  • Så lenge datamaskinen er slått på, kjøres planlagte oppgaver uavhengig av om noen er logget på Windows eller ikke. Hvis du ikke vil kjøre oppgaver når ingen er pålogget, åpner du mappen Planlagte oppgaver før du logger av og velger Stopp Oppgaveplanlegging på Avansert-menyen. Hvis du vil fortsette å bruke Oppgaveplanlegging etter at du har logget på, åpner du mappen Planlagte oppgaver og velger Start Oppgaveplanlegging på Avansert-menyen.
  • Kontroller at systemdatoen og -klokkeslettet på datamaskinen er riktig. Denne informasjonen brukes i Oppgaveplanlegging til å avgjøre når planlagte oppgaver skal kjøres. Hvis du vil endre datoen eller klokkeslettet, dobbeltklikker du klokken på oppgavelinjen.

Beslektede emner


Endre en planlagt oppgave

Slik endrer du en planlagt oppgave

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Høyreklikk oppgaven du vil endre, og velg Egenskaper.
  3. Velg ett eller flere av følgende alternativer:
    • Endre programmet du vil kjøre, ved å skrive inn banen til oppgaven i Kjør-boksen eller velge Bla gjennom.
    • Hvis du vil endre tidsplanen for oppgaven, velger du kategorien Oppgave.
    • Hvis du vil tilpasse innstillingene for oppgaven, velger du kategorien Innstillinger.

Obs!

  • Hvis oppgaveprogrammet krever parametere, skriver du inn disse i Kjør-boksen, etter oppgavebanen.
  • Hvis banen til oppgaveprogrammet inneholder mellomrom, skriver du hele oppgavebanen i doble anførselstegn (").


Fjerne en planlagt oppgave

Slik fjerner du en planlagt oppgave

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Høyreklikk oppgaven du vil fjerne, og velg deretter Slett.

Obs!

  • Når du sletter en planlagt oppgave, fjernes den bare fra mappen Planlagte oppgaver. Programfilen som er tilknyttet oppgaven, fjernes ikke fra datamaskinen.


Avbryte en planlagt oppgave som kjører

Slik avbryter du en planlagt oppgave som kjører

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Høyreklikk oppgaven du vil avbryte, og velg deretter Avslutt oppgave.

Obs!

  • Hvis en planlagt oppgave starter et annet program, avbryter denne kommandoen bare den opprinnelige planlagte oppgaven, ikke den andre oppgaven.
  • Hvis du vil starte en oppgave på nytt, høyreklikker du den og velger Kjør.
  • Så lenge datamaskinen er slått på, kjøres planlagte oppgaver uavhengig av om noen er logget på Windows eller ikke. Hvis du ikke vil kjøre oppgaver når ingen er pålogget, åpner du mappen Planlagte oppgaver før du logger av og velger Stopp Oppgaveplanlegging på Avansert-menyen. Hvis du vil fortsette å bruke Oppgaveplanlegging etter at du har logget på, åpner du mappen Planlagte oppgaver og velger Start Oppgaveplanlegging på Avansert-menyen.


Kjøre en oppgave umiddelbart

Slik kjører du en oppgave umiddelbart

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Høyreklikk oppgaven du vil starte, og velg Kjør.

Obs!

  • Du kan avslutte oppgaven ved å velge Avslutt planlagt oppgave på Fil-menyen.
  • Hvis en oppgave skulle blitt kjørt, men ikke ble det, bør du kontrollere loggen for å finne ut hvorfor. Velg Vis logg på Avansert-menyen.


Vise en logg over tidligere planlagte oppgaver

Slik viser du en logg over tidligere planlagte oppgaver

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Velg Vis logg på Avansert-menyen.


Vise planlagte oppgaver på en ekstern maskin

Slik viser du planlagte oppgaver på en ekstern maskin

  1. Dobbeltklikk ikonet Mine nettverkssteder.
  2. Dobbeltklikk datamaskinen du vil vise planlagte oppgaver for.
  3. Dobbeltklikk mappen Planlagte oppgaver.

Obs!

  • Du kan redigere oppgaver på en ekstern datamaskin bare hvis den eksterne datamaskinen har programvare for ekstern registrering installert og deler x$ der x er harddisken hvor mappen Planlagte oppgaver befinner seg. Datamaskinen må også angi at din bestemte brukerkonto har tilgang til ekstern registrering. Du kan angi hvilke brukere som har tilgang til ekstern registrering til en datamaskin, ved å dobbeltklikke Passord-ikonet i Kontrollpanel


Deaktivere alle planlagte oppgaver midlertidig

Slik deaktiverer du alle planlagte oppgaver midlertidig

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Velg Stopp Oppgaveplanlegging midlertidig på Avansert-menyen.

    Dette er nyttig hvis du kjører et annet program (for eksempel et spill) eller installerer programvare, og du ikke vil kjøre oppgaver samtidig.

Obs!

  • Oppgaver som skulle ha kjørt mens Oppgaveplanlegging er stoppet midlertidig, kjøres ikke før neste planlagte tidspunkt.
  • Hvis du vil gjenoppta tidsplanene for alle oppgaver, velger du Fortsett Oppgaveplanlegging på Avansert-menyen.


Deaktivere Oppgaveplanlegging

Slik deaktiverer du Oppgaveplanlegging

  1. Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.
  2. Velg Stopp Oppgaveplanlegging på Avansert-menyen.

Obs!

  • Når du deaktiverer Oppgaveplanlegging, kjøres ikke de planlagte oppgavene, og Oppgaveplanlegging starter ikke automatisk neste gang du starter Windows.


Feilsøking i forbindelse med Oppgaveplanlegging

Hvis oppgaven du planlegger, ikke kjører når det forventes, høyreklikker du den i oppgavelisten og velger Egenskaper. Kontroller at det er merket av for Aktivert i kategorien Oppgaver. Kontroller at tidsplanen er angitt på riktig måte i kategorien Tidsplan.

Hvis et oppgaveprogram ikke kjører på riktig måte, må du kanskje lage kommandoargumenter for det. Hvis du vil vite mer om et program og argumentene til det, kan du forsøke ett av følgende:

  • Hvis programmet har elektronisk hjelp, kan du se i den.
  • Prøv å skrive følgende etter en kommandoledetekst, der program er navnet på programmet.
    program /?


Åpne mappen Planlagte oppgaver

Slik åpner du mappen Planlagte oppgaver

  • Klikk startknappen, velg Programmer, Tilbehør, Systemverktøy og deretter Planlagte oppgaver.